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@ Having hard time finding an answer
to your question?

Check out our Knowledge Base.
Extension page: http://ecommerce.aheadworks.com/magento-extensions/iphone-theme.html

It’s not just a simple Magento template — actually it’s a revolutionary hybrid of a superior theme and a full-value extension. We’ve enriched its functionality
with AJAX cart and integrated advanced navigation. Say goodbye to annoying page reloads when adding items to cart or searching the store, and browse with

ease and simplicity.

Features

* Fully automatized
The iPhone Theme has its own automatic device type
identification. It detects visitors who browse your website
using a mobile device, and switches between iPhone or
desktop theme.

*~ Advanced User Interface
Theme layout and Ul elements are tailored to the needs of
mobile devices users:

® J|arge fonts and buttons
® fast and seamless store navigation

® instant Account, Search and Cart access from any
page

® AJAX-powered Search and Cart functionality, no
page reloads

Everything eases your iPhone clients browsing.


http://ecommerce.aheadworks.com/magento-extensions/iphone-theme.html
http://ecommerce.aheadworks.com/kbase/extension-iphone-theme/

* Other features
® Device type auto-detection
® Compatibility with
® Android
Windows Phone 7
BlackBerry OS 6
i0S 7
Ability to change logo from admin
Easy to change design and layout
Device rotation support
Multi-shipping checkout
Can be installed on subdomain
Multistore support
Ability to set up footer links and copyright in
backend
® |ntegration with other aheadWorks extensions: B
ooking and Reservations, Subscriptions and
Recurring Payments , Points And Rewards

Installation

Clear the store cache under var/cache and all cookies for your store domain. Disable compilation for Magento 1.4+. This step eliminates almost all potential
problems. It's necessary since Magento uses cache heavily.

Backup Your Data

Backup your store database and web directory.

Download and Extract

Download and unzip extension contents on your computer and navigate inside the extracted folder.

Upload Files

Step 1

Navigate inside step_1 directory. Using your FTP client upload content of step_1 directory to your store root.

Step 2

Navigate inside step_2 directory and upload its content to your store root the same way as it was made in Step 1.

Step 3 (for Magento Enterprise merchants, who use Full Page Cache)

open app/etc/enterprise.xml file and replace

<ee>Enterprise_PageCache_Model_Processor</ee>

with

<l--<ee>Enterprise_PageCache_Model_Processor</ee>-->

<aw>AW_Mobile_Model_Processor</aw>


http://ecommerce.aheadworks.com/magento-extensions/booking-and-reservations.html
http://ecommerce.aheadworks.com/magento-extensions/booking-and-reservations.html
http://ecommerce.aheadworks.com/magento-extensions/subscriptions-and-recurring-payments.html
http://ecommerce.aheadworks.com/magento-extensions/subscriptions-and-recurring-payments.html
http://ecommerce.aheadworks.com/magento-extensions/points-and-rewards.html

Final step of the installation.

One more time clear the cache under var/cache and login to Magento backend (admin panel). In case you have already been logged in during the installation,
logout and login back.

Configuration

Mobile Theme Settings | Product Page | Design | Behaviour | Google Analytics

The configuration section of the iPhone Theme extension is located in System > Configuration > aheadWorks Extensions > Mobile page in the backend.

Mobile Theme Settings tab
® Enable option - enables / disables the mobile theme and the
associated functionality

® Disable automatic scroll to menu (default value is "No") - this option
defines whether or not the header section will be automatically
skipped when a visitor navigates to a page.

@ w What does it mean?

The iPhone Theme extension is tailored to provide maximum
usage convenience for small-dimensions screens. The default
behavior of the extension is to automatically scroll the page
down to the Categories list when a customer navigates to a
page. This behavior works identically with any device
orientation (vertical / horizontal)

l.e., if the Disable automatic scroll to menu option is set to "No
", a page will look like this:

Electronics

Books

Product Types

NOTE: the Header section is still there, a visitor will see it if
they scroll up the page

If the Disable automatic scroll to menu option is set to "Yes",
the page will be displayed as per usual, with the Header on top:

rEvolution Login My Account

coes U Q e [ e 3

Electronics

Books

Enable Yes | [STORE VIEW]

Disable autematic scroll to menu Mo j [STORE VIEW]




Product Page tab
® Display Additional Data - enables / disables the correspondent block
in the product details

w How does it look like?
The highlighted block is enabled / disabled by this option:

Details

The novel takes place following the First World War.
American society enjoyed prosperity during the "roaring”
19205 as the economy soared. At the same time. Prohibition,
the ban on the sale and manufacture of alcohol as
mandated by the Eighteenth Amendment, made millionaires
out of bootleggers. After its republishing in 1945 and 1953, it
quickly found a wide readership and is today widely
regarded as a paragon of the Great American Novel, and a
literary classic.

Additional data

SKU sku-10
author F. Scott Fitzgerald
Cover Paperback
pages 555

Product Views

Product Page

Display Additional Data Yes =l [STORE VIEW]

Design tab

In the Design tab, you can choose logo, define logo image alternative text, and
specify the image for the iPhone bookmarks of your store. If you have a
multistore, set up the store view for each of them in the Custom Design field.
While customizing footer links, use the automatically created Mobile Footer
Link (Example) static block.

Design
Catalog Logo Image [STORE VIEW]
Catalog Logo Alt | [STORE VIEW]
Bookmarks Icon Source [STORE VIEW]
Custom Design |—F’Iease Select— j [STORE VIEW]
If not defined, default mobile design is used
Footer Links Block |I'v|ob\|e Footer Links (Example) j [STORE VIEW]
If not defined, default mobile links are used. Use
automatically created "Mobile Footer Links (Example)
static block as an example
Footer Copyright (c) aheadWorks Co, 2014 [STORE VIEW]

Behaviour tab
® Desktop/Mobile Switcher - shows / hides the Switcher Link in the
footer.



{D » What is the "Switcher Link"?
The iPhone Theme extension is capable of automatic device
type detection, and by default, the module delivers either
mobile or desktop view depending on the device. In addition to
this, the extension allows switching between the 2 views manu
ally, at any time and on any device.

Special Switcher Link intended for this purpose can be included
in the footer sections:

Us | & RSS | Mobile Version

| Contact | RSS
IS Dollar - USD vI Desktop Version
014

NOTE: In case you are using a custom Footer block in the
desktop view, the module may be unable to add this link. In
such case, the link can still be inserted manually.

® For switching from Desktop View to Mobile View, the
link should look like this: " yourdomain.com/index.ph
p/awmobile/switch/tomobile/ "

® For switching from Mobile View to Desktop View, the
link should look like this: " yourdomain.com/index.ph
p/awmobile/switch/todesktop/ "

® Mobile Detect - this option defines if the module will automatically
identify the smartphone visitors. If this option is disabled, all the
visitors will arrive at the desktop site version. The mobile view will
only be available via the Switcher link

® Tablet Detect - this option defines if the module will automatically
identify the tablet devices. If this option is disabled, tablet users will
arrive at the desktop site version. The mobile view will still be
available via the Switcher link.
Note: this option has lower priority than the "Mobile Detect" one. If
the latter is disabled, all the visitor will be delivered desktop view

® iPhone Cache - this option enables / disables caching the content in
visitors' browsers (by passing special parameters to the customer's
device)

® Pper-store configuration - there are several more options, which are
only available for per-store setup. See details here.

Behaviour
Desktop/Mobile Switcher Yes j [STORE VIEW]
Mobile Detect Yes FEl  1sToREVEW
Tablet Detect No =l [STORE VIEW]
iPhone Cache Yes =l [STORE VIEW]
Per-store configuration Ifyou want te configure autematic switching to mobile [WEBSITE]
view or redirect to mobile version for specific store
please change current configuration scope
Google Analytics tab

The iPhone Theme extension allows using a separate Google Analytics account



to track the mobile view traffic specifically.

If no GA account is specified in the extension's settings, the mobile view traffic
will be counted together with that of the desktop view.

Account Number [STORE VIEW]

Setting up iPhone theme on a subdomain

@ This step is not necessary, use it only if you need to use a dedicated subdomain for mobile theme (i.e. mobile.shop.com)

Since iPhone theme 1.6.1, advanced options for theme usage on a subdomain have been implemented.
1. Create a new store view and setup a dedicated domain (mobile.shop.
com) the way it is described in this tutorial . Nginx server users can
find required information in Magento Wiki
Please note, as this feature requires an Apache or Nginx
configuration, you may need to contact to your server administrator
or hosting provider regarding the matter.
2. Go to System->Configuration->aheadWorks
Extensions->Mobile->Behaviour (make sure to select the proper Confi
guration Scope)

Current Confiouration Scope:
English [mobile] =lle
WManage olores

3. Set option Always switch to mobile view to Yes (so the users who
come to shop.com will always see a mobile version of the site:
m.shop.com)

4. Set option Enable redirect to store to Yes (this option is not applicable
in a single store environments). If this option is set to No, the
extension will use an option Mobile Detect or Tablet Detect (dependi
ng on mobile device of a customer).

5. In the Redirect to store field, select the desktop store view, which
corresponds to your currently selected mobile store view

Behaviour

Deskiop/Mobile Switcher Yes j ¥ Use Website [STORE VIEW]
Iobile Detect Yes j ¥ Use Website [STORE VIEW]
Tablet Detect No j ¥ Use Website [STORE VIEW]
iPhone Cache Yes =l W usewebsite (sTORE ViEW]
Always switch to mobile view Yes j [STORE VIEW]
Enable redirect to store Yes j [STORE VIEW]

Not applicable with single store
Redirect to store English [deskiop] =l [STORE VEEW]

To prevent incorrect behavior please do not set here

current store view and dont set recursive redirects

Uninstallation


http://www.magentocommerce.com/knowledge-base/entry/tutorial-multi-site-multi-domain-setup
http://www.magentocommerce.com/wiki/1_-_installation_and_configuration/configuring_nginx_for_magento
http://www.magentocommerce.com/wiki/1_-_installation_and_configuration/configuring_nginx_for_magento
http://www.magentocommerce.com/wiki/1_-_installation_and_configuration/configuring_nginx_for_magento

1. Disable compilation, in case it is enabled.
. Login to your FTP, navigate to app/etc/modules/
3. Open the file AW_Mobile.xml and change the following line:

N

<active>true</active>

to

<active>false</active>

4. Clear the cache under var/cache
. Make sure that the site is working properly, otherwise roll back the changes and apply to our technical support.
6. If everything works fine, it is safe to delete the files of the extension.

w

Troubleshooting

After the extension installation the store gives an error, or blank page, or suggests to start Magento installation procedure.
Change the owner of the extracted extension files to the web server user and set 775 permissions on them. Clear the store cache and try again.
There is no aheadWorks extensions under my configuration section, or having the extension tab clicked | get a blank page, or Access Denied error.
Clear the store cache, browser cookies, logout and login again.
I've set up everything correctly, inserted the HTML code but there is nothing on that page.
Clear the store cache, clear your browser cache and domain cookies and refresh the page.
My configuration changes do not appear on the store.

Clear the store cache, clear your browser cache and domain cookies and refresh the page.

You can always find the latest version of the software, full documentation, demos, screenshots and reviews at http://ecommerce.aheadworks.com
License agreement: http://ecommerce.aheadworks.com/LICENSE-M1.txt
Contact us: http://ecommerce.aheadworks.com/contacts/
Copyright © 2019 aheadWorks Co. http://www.aheadworks.com
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